What features would you like to see in future versions of Joomla?

Complete compatibilty with CloudFlare CDN Network

I'd like to see the Joomla! project liaise with CloudFlare to ensure that Joomla! and CloudFlare are completely compatible.

At present, there are issues in both the Joomla! v2.5.x and v3.3.x series where when an account is on CloudFlare, certain Admin buttons (like [Save], [Save & Close] etc.) in some core components just don't work :-(

6 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Peter KORTGEPeter KORTGE shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Peter KORTGEPeter KORTGE commented  ·   ·  Flag as inappropriate

        Hi Walt:

        Yes, all my servers run the mod_cloudflare extension (so no need for the CloudFlare plugin to fix visitor IP Addresses).

        However, it doesn't fix the various ongoing problems with Joomla!.

        And problems also occur with Gantry v4 RocketTheme templates in the template backend wherein buttons and the "layout" sliders don't work, so you need to "pause" CloudFlare while you make template changes and then "resume" CloudFlare when finished.

        Lastly, I've also recently (Feb 2015) tested CloudFlare's free "Flexible SSL" option together with SimBunch's free CloudFlare for Joomla! plugin (cloudflareunissl_system).

        When the plugin is installed sites load/work OK with the Safari web browser, but under Google Chrome sites don't work/render properly due to the fact that Chrome says that all .css scripts etc. are "http" but are being called from "https" so won't be loaded :-(

        FYI: I've recently spoken to the RocketTheme people who have given assurances that Gantry v5 will be compatible with CloudFlare.

        Now just need to get the Joomla! Devs onboard as well :-)

      • WaltWalt commented  ·   ·  Flag as inappropriate

        Are you using the CloudFlare Joomla Plugin? Does your host run apache? if yes, do they support cloudflare with mod_cloudflare for Apache httpd? or the IIS module if you are on IIS? (note: If your web server is already running the mod_cloudflare extension, the CloudFlare Joomla Plugin is not required.)

        Since CloudFlare created and maintains a "CloudFlare Joomla Plugin" I would suggest contacting them in regards to the issues you are experiencing.

      Feedback and Knowledge Base